675.cc • Triumph 675 Forum

Expansion tank lid

Discussion in 'Maintenance & Tweaks' started by SteveH, Oct 17, 2009.

  1. SteveH

    SteveH

    Thread Starter

    648
    0
    0
    Location: Oxford-ish
    Hi all,

    Is anyone having problems with their coolant expansion tank lid not sealing properly? Mine seems to be leaking slightly and spewing out coolant all over the frame and general l/h/s of the bike. Getting a bit annoyed with it now. The bikes still only got about 2.5k on the clock so it better not be developing a serious problem or I shall be very un-impressed.

    Cheers

    Steve
     
  2. have you read the post about colant level by henrymc perhaps you have to much coolant in your expansion tank
     
  3. henrymc

    henrymc

    794
    0
    0
    Location: lincoln
    Hi Steve,
    mine was spitting coolant out of the overflow as i said on the thread,
    seems the 675 should be run on the min level in the expansion tank,
    hope this helps.
    keep us posted as to how you get on,
    dont think it will be the cap on the expansion tank you are looseing coolant as it is just a push on jobie but you never know.
     
  4. Also check the plastic moulding on the lip of the tank. Some people have found the moulding uneven preventing a good seal, you can just cut the offended bumps smooth with a knife if you find any.
     
  5. Deegee

    Deegee Moderator Staff Member

    7,934
    2
    38
    Location: In the Garage.
    Plastic elbow syndrome? just wondering if it's coming out of a crack in the infamous elbow and being blown back onto the cap area?

    Would be an easier fix than what you're thinking Steve...
     
  6. D41

    D41

    13,990
    143
    63
    Location: Orange, CA
    The expansion reservoir should only be filled to the "minimum" level.
     

Share This Page

Loading...
  1. By using this website you agree to our Cookies usage. We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters:
    Dismiss Notice