675.cc • Triumph 675 Forum

Fault Light

Discussion in 'Maintenance & Tweaks' started by keithspurs2000, Mar 27, 2009.

  1. keithspurs2000

    keithspurs2000

    Thread Starter

    200
    0
    0
    Location: Market Drayton
    My engine fault light came on the other day and i booked it into the dealer. They rang me yesterday to tell me they had fixed the fault (exup valve) and i could come and pick it up. Just went and picked the bike up and the light came on again on the way home. I rang the dealer again and they're ordering me a new exhaust part. :D Can anyone tell me what is is they are changing. Surely its only that particular part of the exhaust. Also when it's changed has anyone else had a reoccurance of the same problem or does it fix it permanently.
    cheers.
     
  2. Craig

    Craig Administrator Staff Member

    4,884
    226
    63
    Location: Maidstone
    The exup valve is a common problem with becoming out of adjustment - it controls the pressure in the exhaust and increases low rpm torque. Usually a simple fix from the dealer, though like all things can be the start of numerous things. Have a look at mike675's posts in the following thread -> viewtopic.php?f=14&t=201
    He had probs with the valve getting stuck open, making the bike go into a sort of limp mode - caused by cold weather allegedly :?: Always fight for the warranty; from what I've seen when most people have had it fixed, it hasn't returned but then that's not to say it wont happen again :evil: maybe someone who's had first hand experience of this can elaborate a bit more.

    Keep us posted on the situation! :)
     

Share This Page

Loading...
  1. By using this website you agree to our Cookies usage. We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters:
    Dismiss Notice