675.cc • Triumph 675 Forum

warning light AGAIN

Discussion in 'General' started by tractorboy, Apr 17, 2009.

  1. tractorboy

    tractorboy

    Thread Starter

    30
    0
    0
    hi`everyone :D bike is going back in again for the 3rd time on tuesday :( for the dreaded engine warning light.has anyone had this problem yet with the 09 bike or have triumph sorted it/just wondered as they seem to not accept there has been a problem :?
     
  2. friggin ek, am i the only one on here that hasn't had this issue, every time i go out i keep expecting this damn light to go on.
     
  3. tractorboy

    tractorboy

    Thread Starter

    30
    0
    0
    you iron urchin are a very lucky man :D
     
  4. Stu

    Stu

    716
    0
    0
    Location: Leeds
    I'll just put some voodoo on you bike IU. :D
    It will be on by Sunday :D
     
  5. tractorboy is it the exup valve sticking thats putting it on. if so its really easy to free yourself. save you taking a trip to the dealer and having to wait for it to get sorted. itll take half an hour or so doing it yourself.
     
  6. jimjam39

    jimjam39

    501
    0
    16
    Location: Wrexham
    Not had it on my 09 yet, mind you iv'e only had it a month ;)
     
  7. BigBoulton

    BigBoulton

    102
    0
    0
    Location: Plymouth
    Had mine jus over a year and not had any lights on yet (Touch wood!), apart from those nice blue ones :twisted:
     
  8. Stu

    Stu

    716
    0
    0
    Location: Leeds
    How do you free it Keith that's easy? I waggled and oiled the spindly bit at the end of the cables which has sorted the light on Jean's bike but last time it was new cables which isn't an easy job. You are supposed to use the diag tool to set the valve open so the cables can be adjusted. Fortunately having two 675's I have one to compare against :)
     
  9. i never adjusted anything just took it apart and oiled and freeed it up. a bit of copper grease for lube and its sorted. worked on mine so far.
     
  10. cheers m8, you must be a crap witchdoctor cos it aint come on yet..... doh! what have i done :eek:
     
  11. Stu

    Stu

    716
    0
    0
    Location: Leeds
    Oh dear. Have you woken a sleeping beast :D
     
  12. kingfixer

    kingfixer

    2,045
    25
    48
    Location: bristol
    Mine has come on for the 2nd time today..not good!! 2 weeks before they can look at it ! most probably the same thing as last time. :(
     
  13. I've got a PDF file from another 675 site showing how to you can loosen up the exup valve amongst other things. Send me your email and I'll forward you on a copy.
     
  14. keith - can you post it for all of us. Craig - can you put it in the knowledge base?
     
  15. craig send me your email and ill send the file
     
  16. kingfixer

    kingfixer

    2,045
    25
    48
    Location: bristol
  17. The Fridge

    The Fridge

    224
    3
    16
    Location: Leeds
    Hi Keith dont no if CraigS got the info 4 every1, but cud u send me file too to loosen up the valve. havnt had a prob yet, but better to b 4warned! Ta, Dave
    [email protected]
     
  18. Craig

    Craig Administrator Staff Member

    4,855
    222
    63
    Location: Maidstone
    Hey that'll be great... my email is [email protected]

    I'll try and put it up for everyone on the site.. the more info the better ! :)
     

Share This Page

Loading...
  1. By using this website you agree to our Cookies usage. We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters:
    Dismiss Notice