675.cc • Triumph 675 Forum

What is this for?

Discussion in 'Maintenance & Tweaks' started by OnlyOneWayHome, Apr 27, 2009.

  1. OnlyOneWayHome

    OnlyOneWayHome

    Thread Starter

    491
    0
    0
    Location: Lancashire
    Hi All,

    While cleaning my bike this weekend, I saw an electronic connector not actually connected to anything, located under the rear suspension (Pics below). Should it be connected to something and if not, why's it there?




    Thanks
     

    Attached Files:

  2. Rowly

    Rowly

    870
    0
    0
    Have you got an alarm immobilizer fitted? if not it may be that, I have one
    the same but its under my seat.
    Or maybe a diagnostic test connector block?
     
  3. might be something to do with a quickshifter.. :?
     
  4. OnlyOneWayHome

    OnlyOneWayHome

    Thread Starter

    491
    0
    0
    Location: Lancashire
    I have the standard Triumph/Datatool alarm fitted. On further inspection, it seems to be atached to a loom that goes to the rear brake.
     
  5. Rowly

    Rowly

    870
    0
    0
    Best advice is ask your dealership they'll know what its for and will also
    put your mind at rest? ;)
     
  6. Edski675

    Edski675 Administrator Staff Member

    Can't say i recall seeing that on my bike.
     
  7. AcB46

    AcB46

    131
    5
    18
    Location: Bradford
    I don't have any wires near my rear shock(at least i don't think i have) it defo not the diagnostic connector, that is the one under the seat that looks kinda like a scart lead.
     
  8. Yes I have one on my 07 D675. I mean to ask the dealer everytime I go in but it always slips my mind but I figure that it is probably something to do with bikes that are exported out of the UK prob to the USA. Also it cannot be that important as I have done over 3000 miles without it being connected to anything.

    Midgeman.
     
  9. OnlyOneWayHome

    OnlyOneWayHome

    Thread Starter

    491
    0
    0
    Location: Lancashire
     
  10. Stu

    Stu

    716
    0
    0
    Location: Leeds
    I think it may be where the California evaporation canister may plug in. Dunno?
     
  11. dont know what that is, but it sounds really cool :D
     
  12. Graham H675

    Graham H675

    258
    1
    18
    Location: surrey
    evap canister emmission item and power sapping lol will look on me bike tommrrow
     
  13. Jap_Sti_3

    Jap_Sti_3

    724
    0
    0
    Location: Rochdale
    :?: :?: :?: :roll: :roll: :roll: :?: :?: :?: No Bl***y Idea :geek:
     
  14. Craig

    Craig Administrator Staff Member

    4,881
    224
    63
    Location: Maidstone
    haha my thoughts exactly! :p
     
  15. OnlyOneWayHome

    OnlyOneWayHome

    Thread Starter

    491
    0
    0
    Location: Lancashire
    Are you telling me that I may be missing my Lancashire Evaporation Canister !!!!!!!!
     
  16. Stu

    Stu

    716
    0
    0
    Location: Leeds
    My tyke evaporation canister fell off on the M62. I never bothered with another :D
     
  17. It is for the evap cansiter, i have seen it mentioned on other forums.
     
  18. RICH675

    RICH675

    559
    38
    28
    Location: Merseyside
    AH HA. I SEE YOU DON'T HAVE YOUR FLOO FLOO VALVE CONNECTED.
     
  19. Bless you :lol: :lol:
     

Share This Page

Loading...
  1. By using this website you agree to our Cookies usage. We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters:
    Dismiss Notice