675.cc • Triumph 675 Forum

Yellow light of death

Discussion in 'General' started by 675 hazza, Oct 12, 2009.

  1. 675 hazza

    675 hazza

    Thread Starter

    5,640
    29
    48
    So it's Monday morning, wheeling the old gal out the garage to go to work, start her up, bit of a pop and the yellow light of death dose NOT go off, argh!!!! The poxy thing had it's 12,000 mile service 3 weeks ago!! :evil: So rode it to work like a donkey
    off to jack lilleys I go again for the forth time this year..... Who would ever get a british bike!
     
  2. kingfixer

    kingfixer

    2,045
    25
    48
    Location: bristol
    Exup valve i bet !! Still a great bike though :D
     
  3. Ive had loads of exup issues in the past. But ive been leaving the bike on trickle charge after some feedback from my dealer about battery power and not having enough to move the valve.
     
  4. 675 hazza

    675 hazza

    Thread Starter

    5,640
    29
    48
    Mmm luckily I've not had the old exup valve go tho I've been told buy many it's a deffinant go, so maybe it is, but one guy said his bike wouldn't start? So I hope mine still starts after work when I gotta take it to the dealership! :?
     
  5. jimjam39

    jimjam39

    501
    0
    16
    Location: Wrexham
    Is it me or have you got a gold front wheel and a grey one on the back ? Whats that all about ?
     
  6. the bike will still start with a dodgy exup valve! It may sound rough and cough and splutter for a while but the ecu should recognise this and fully open the valve, you will also heaer the exhaust note change
    if you havent alredy insist to your dealer to chnage the exhaust headers and cables plus get them to check over the valve motor as well, they should be well aware of the issues.
    if they dis-agree give triumph customer services a call they will also help.

    All this is irrelevant if its not a exup problem!!
     
  7. 675 hazza

    675 hazza

    Thread Starter

    5,640
    29
    48
    Yeah it turned out to be the cables had rotted an snapped, abit strange that they didn't mention the state of it when it had it's 12,000 mile service a few weeks ago, they said they'd lubed up the valve an there was nothing wrong with it, yet!
    They charged me £24 labour an £28 for the part, they didn't charge me VAT on the the part so it was about £62 with the other VAT, I asked for the broken part back an the cables were dry so I ashume they don't lube the cables in the sleeves they sit in?


    As for my different color wheels, a man an his car wrote my bike off for me, I got £4,000 for the bike an got her back salvage coz she was mechanically sound, it was plastic an the steering lug on the frame that wrote it off, fixed the bike up with my dad an was some scratches on the wheel an a can of gold paint lying around, so this was the out come of my dads wrath as he ran out of paint half way, cheers dad! But I wanna get them both power coated gold in a poor attemp at making it look like the SE!
     
  8. jimjam39

    jimjam39

    501
    0
    16
    Location: Wrexham
    Well that explains that then :D
     

Share This Page

Loading...
  1. By using this website you agree to our Cookies usage. We and our partners operate globally and use cookies, including for analytics, personalisation, ads and Newsletters:
    Dismiss Notice